Unable to load Dashboard and Widget stuck at reconnecting

Incident Report for tawk.to

Resolved

This incident has been resolved
Posted Dec 05, 2025 - 09:24 UTC

Identified

The source of the failure has been identified as an issue with our upstream provider
We are closely monitoring the incident and taking steps to resolve it
Posted Dec 05, 2025 - 09:08 UTC
This incident affected: Dashboard and Widget.