We are seeing traffic recovering, some user might not be able to load the website while we are closely monitoring the incident
Posted Nov 18, 2025 - 16:38 UTC
Identified
The source of the failure has been identified as an issue with our upstream provider We are closely monitoring the incident and taking steps to resolve it
Posted Nov 18, 2025 - 12:11 UTC
This incident affected: Website, Dashboard, Widget, and Hosted Pages.