Shipping major updates to widget
Incident Report for
tawk.to
Resolved
This incident has been resolved.
Posted
May
22
,
2021
-
11:34
UTC
Monitoring
We will be undergoing scheduled maintenance during this time.
The widget will be down during this period.
Expected restoration of service at 11.30 AM UTC
Posted
May
22
,
2021
-
10:30
UTC
This incident affected: Dashboard and Widget.
×
Subscribe to Incident
Subscribe to updates for
Shipping major updates to widget
via . You'll receive .